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1. PrintMaster 2020 USER GUIDE 
 

Unleash your imagination with PrintMaster 2020, the quintessential toolkit for creating thousands 

of amazing projects – photo greeting cards, family newsletters, scrapbook pages and much more! 

With an enormous library of designer templates, premium artwork and expressive fonts, 

producing "professional-quality" creations has never been easier. Let’s get started. 

 

2. What's New in PrintMaster 2020? 
 

• Enhanced User Interface 

• Share Project by Gmail 

• Create Custom Borders 

• Line Arrowhead 

• Line Patterns 

• Change Shape Outline 

• Add Customize Text into Shape 

• New Auto-Save Functionality 

• Improved Printing Wizard 

• Customized Print Options 

 

3. Key Features in PrintMaster 2020? 
 

• Over 15,000 + Brand New, Royalty-Free, Commercial-Use  

• Ready-Made Templates 6,500 + 

• Clip Art and Images 20,000+ 

• Royalty-Free Ready-made Templates 1,000 + 
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• Modern User Interface  

• Powerful New Text Handling Capabilities 

• New Address Book and Mailing Features 

• Master Project Page for Multipage Projects  

• New Photo Fonts, Paint Brushes, and Styles 

• New Right- Click Snap to Guideline, Center and Edge Options  

• Paint functionality is included in Design Tools 

• A line Thickness feature included in Shapes and Lines 

• Search Functionality Added in ClipArt 

4. Video Tutorials 
 

Video Tutorials are available that demonstrate many of the new features found in PrintMaster 

2020:   https://www.youtube.com/channel/UCatgw37O3mupzZDSNVxS_yA/videos 

5. Usage of this Guide 
 

This guide is separated into 4 major sections: 

1. Installation and Recommendations. 

2. Interface Reference. 

3. How to use PrintMaster 2020. 

4. Sharing Completed Projects. 

 

 

 

 

 

 

https://www.youtube.com/channel/UCatgw37O3mupzZDSNVxS_yA/videos
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6. Overview of New Features 
 

6.1. Enhanced User Interface:  
 

We have improved the UI of PrintMaster 2020 by changing its theme. Figure 6.1 is an example of 

the user interface’s new look and feel and is easier to use than the earlier version of PrintMaster. 

 

 
Fig 6.1: Enhanced User Interface 

 

6.2. Share Project by Gmail: 
 

In the 2020 version of PrintMaster, you can share your project through Gmail. Users can share a 

project by entering his/her email address and receiver email addresses. Fig 6.2 

 

 

Fig 6.2- Share Project by Gmail 
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6.3. Create Custom Borders: 
 

Users can add a custom border in PrintMaster by adding images to the borders, changing colors, and 

adding text in it. Fig 6.3  

 

 
Fig 6.3: Create Custom Borders 

 
 

6.4. Line Arrowhead 
 

PrintMaster 2020 allows users to add different types of arrowheads on line to point something in 

a particular dimension. Fig 6.4 

 

 
Fig 6. 4: Line Arrowhead 
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6.5. Line Patterns 
 

PrintMaster 2020 allows users to change line patterns such as dotted, square boxes and more. 

Fig 6.5 

 
Fig 6.5: Line Patterns 

 

6.6. Change Shape Outline 
 

In PrintMaster 2020 users can change a shape’s dimensions and can customize it accordingly. Fig 

6.6 

 

 

 
Fig 6.6: Change Shape Outline 
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6.7. Add Customize Text into Shape 
 

From this functionality, users can change and customize text inside shape by changing its style 

like bold italic, height, width, and size. Fig 6.7 

 

 
Fig 6.7: Add Customize Text into Shape 

 

6.8. New Autosave Functionality 
 

The autosave functionality will save your project every few minutes or based on the parameters 

you set and help minimize the loss of your project. Fig 6.8 

 

 

 
Fig 6.8: New Autosave Functionality 
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6.9. Improved Printing Wizard 
 

Print Preview has been added to allow a user to view their projects. Fig 6.9 

 

 
Fig 6.9: Improved Printing Wizard 

 

6.10. Customized Print Options  
 

Users have the option to customize the printing options. Users can print all pages, one page, or 

selected pages. Fig 6.10 

 

 
 

Fig 6.10: Customized Print Options 
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7. INSTALLATION AND RECOMMENDATIONS 
 

7.1. System Requirements 

Prior to installing PrintMaster 2020, ensure that your computer meets the following: 
Windows: 

• Windows 7, 8 or 10 

• 2 GB RAM or more recommended 64 MB video RAM recommended) 

• DVD‐ROM drive 

• Available Hard Disk Space: Install disc requires about 3.0 GB (Platinum) or 
1.7 GB (Gold). Downloadable clip art and templates ca 
require up to 36 GB (Platinum) or 22 GB (Gold) of hard drive space. 

• Broadband internet connection required Keyboard and mouse 
 

7.2. System Settings 
• Monitor Resolution: 1152 x 864 or higher recommended 

• Recommended Additional Equipment  
1. Printer 

2. Digital Camera 
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8. Installing PrintMaster 2020 
8.1. Installing PrintMaster 2020 from disc:  

1. Insert the PrintMaster 2020 disc into your computer DVD drive. 

2. The disc should open automatically. If it does not double‐click 
on the disc icon. 

3. Double‐click on the PrintMaster 2020 installer icon or setup.exe. 

4. You will be prompted to open or run the application, click Open or Run. 

5. If prompted, enter your computer password, or if prompted with a UAC select Yes. 

6. Keep the default settings and locations, if you need to do a custom installation, 
please reach each step carefully. 

7. The installation will automatically open a web page to register.  

8. When done registering, close the page to return to the installer. 

9. When installation gets completed, click Finish to close the installation window. 

 

8.2. Installing PrintMaster 2020 from the download:  

1. Select the download link from the provided site or email. 

2. The download will begin automatically, please be patient while it downloads. 

3. If you are using Safari or Google Chrome, it will download automatically once the 
link is clicked. 

4. If you are using IE or Firefox, you may be prompted to Save or Open a file, choose 
Save. 

5. After the download completes the installer will be saved in your Downloads folder 
by default. 

6. Open your downloads folder. (HD or C:/Users/<current user>/Downloads) 

7. Double‐click on the PrintMaster 2020 installer. 

8. You will be prompted to open or run the application, click Open or Run. 

9. If prompted, enter your computer password, or if prompted with a UAC select Yes. 

10. Keep the default settings and locations, if you need to do a custom installation, 
please reach each step carefully. 

11. It will automatically open a web page to register. When done registering, close the 
page to return to the installer. 

12. When installation gets completed, click Finish to close the installation window. 
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8.3. Important Project Information 

To avoid problems while creating projects, please review the following:  

 
1. Do not delete your project files. Keep your project and all related 

files on your computer’s hard drive until you have created the final 
output (print, photo album, etc.). 

2. Check your project.  
 

Follow the steps in the Check Project menu prior to sharing your project. 

a) Exit the software. Always exit the software before turning off your 
computer to avoid corrupting your project. 

b) Adequate hard drive space. Projects require large amounts of hard 
drive space. Ensure you have a minimum of 10GB available disk 
space. If you run out of space while you are building your project, 
you may lose some of your work. 

c) Backup your projects. To avoid losing your work, we recommend 
occasionally backing up your projects to an external drive. (File menu 
> Save As) 

d) Trim area for uploaded projects 1/2" Prevent images and text from 
being cut when professionally printed by keeping the layout within 
1/2” on all sides. 

e) Updates. Occasional updates include enhanced features and bug 
fixes. We recommend installing any updates. (Help menu > Check for 
updates) 

 

8.4. Avery® Template Support 

1. PrintMaster 2020 includes project types that are compatible with Avery templates 
(see https://www.avery.com/ for information on Avery products). 

2. Check the description of Ready- Made project templates and custom project types 
when creating your project for information about Avery template compatibility. 
Make a note of the Avery template(s) the project is compatible with. 

3. Printing Multiple Single Items on an Avery Template 

4. Certain project types, like mailing labels and business cards, can be formatted for 
printing on an Avery template. After creating the project, choose Edit > Convert to 
Full Avery Sheet from the menu. Then print the project to the appropriate Avery 
template. 

5. The project type must be Avery-compatible with this menu option to be enabled. 
 

 

 

http://www.avery.com/
https://www.avery.com/
http://www.avery.com/
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9. INTERFACE REFERENCE 
 

PrintMaster 2020’s interface can be divided into five areas as shown in fig 9.- 

 
1. Page Canvas- The canvas is, where you can create the project by adding backgrounds, 

images, and other objects on the page. 
2. Page Thumbnails- The bottom area displays thumbnails of your pages. In addition, 

you can delete or rearrange the page order. 
3. Gallery: Add page elements from this panel into the canvas with a double‐click 

or drag and drop. 
4. Menus and Toolbars: Most application functions can be accessed through this tab. 
5. Design Tools: Add and edit your project elements by using these panels. 

 

 

 Fig 9: Interface Reference 

9.1. Page Canvas: 
 

Add backgrounds, clip art, images, text, and other objects to create your projects. 
 

Right‐Click Options: 

1. Right-clicking on an empty page canvas brings up paste options. Fig 9.1 
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Fig 9.1: Right-Click Options 

 

2. Right-click on an object to bring up the following options: 
 

• Bring to Front – Places the object on top of all other objects. 

• Send to Back – Places the object behind all other objects. 

• Bring Forward – Moves the object up one layer. 

• Send Backward – Pushes the object back one layer. 

3. Align: Provides the following options for aligning objects with each other, or the page: 

 

• Top ‐ Aligns all selected objects to the top‐most object on the page. 

• Middle ‐ Lines up the vertical middle of each selected object. 

• Bottom ‐ Aligns all selected objects to the bottom‐most object on the page. 

• Left ‐ Align all selected objects to the leftmost object on the page. 

• Center ‐ Lines up the horizontal center of each selected object. 

• Right ‐ Aligns all selected objects to the right‐most object on the page. 

• Center Vertical ‐ Places all selected objects in the vertical center of the page. 

• Center Horizontal‐Places all selected objects in the horizontal center of the 

• page. 

• Space Evenly – Horizontal – Horizontally spaces each object equal distances. 

• Space Evenly – Vertical – Vertically spaces each object equal distances. 
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4. Group: Fixes the position of objects in relation to one another so that they can be 
moved, resized, and rotated without changing their position relative to each other: 

• Mirror Group – Mirrors all objects in the selected group horizontally. 

• Flip Group – Flips all objects in the selected group vertically. 

• Ungroup – Returns a group of objects to individual objects. 

5. Round Corners: It allows you to toggle each corner of the image to round or sharp.  

6. Set Photo as Background: Sets the selected photo as the page background. 

7. Rip Photo Edges: Randomly rips one or more edges of the selected photo. 

8. Attach to Shape: Select both a text box and a shape by holding shift, the text will then fill 
the shape. 

9. Detach from Shape: Removes the text from an attached “text to shape” object.  

10. Hi-Res Preview: Shows a print quality preview of the selected object. 

11. Cut: Removes a page object from the page, but saves it in memory.  

12. Copy: Saves a page object in memory. 

13. Paste: Paste the page object onto the page. Posted objects will be slightly offset.  

14. Edit Object: Object size, location, and information. It also lets you adjust the size.  

15. Delete: Removes a page object from the page. 

16. Lock Object: Locks the object so that it cannot be edited. 

17. Unlock page Object: If you right-click on a locked object, you may unlock it to edit it. 

18. Span Pages: If you have page spreads enabled: Use this feature to allow the image to 

span between pages, rather than being cut when it reaches the edge of the canvas. 

19. Double‐Click: 

• Double-click a photo to open the crop function. 

• Double-click a photo box, to add a photo to the empty box.  

• Double-click a clip art or shape to bring up object settings. 

• Double-click a text box to edit the text. 

• Double-click a headline to edit the headline. 

• Double-click a calendar to open the Calendar Settings window.  

• Double-click a paint box to add new brush lines or erase. 
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9.2.  Page Thumbnails 

The bottom portion of PrintMaster 2020 displays a thumbnail of the pages in the project. 
Fig 9.2 

 

 

Fig 9.2: Page Thumbnails 

1. Reordering Pages: To move a page to a different position in the 

project, click on the page thumbnail, hold down the left-mouse 

button, and drag the page right or left for a new position and 

release. 

2. Right‐Click Options: Right-clicking on a thumbnail displays the 

following functions: 

• Insert Page After – Opens the Add New Page dialog. Create a new 
page with the selected layout after the page you right‐clicked on. 

• Insert Page Before – Opens the Add New Page dialog. Create a new 
page with the selected layout before the page you right‐clicked on. 

• Insert Duplicate Page – Makes an exact copy of the right‐clicked 
page. 

• Delete Page – Removes the page that you right‐clicked. 
 

9.3. Resource Gallery 

Displays all images in the current folder or content category. Select an icon 
to change what type of content is displayed. Easily add elements from the 
gallery to the page canvas with a double-click, or drag and drop. Fig 9.3 
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Fig 9.3.: Resource Gallery 

 

1. Photos: Displays a list of images from a selected folder. 
2. Clip Art: Displays a list of clip art from the selected category.  
3. Backgrounds: Displays a list of background papers from the 

selected category.  
4. Shapes: Displays a list of shapes from the selected category. 
5. Layers: Displays a list in order from top to bottom, of the items 

on your page:  

• Drag an object above, or below another in the list to change the layer 
position. 

• Double-clicking a layer in the list will select the object on the page. 

• Hide objects by clicking the checkbox. 

• Lock objects by clicking the lock icon. 

• Right-click on a layer object to preview, edit, or delete it. 
 

6. Layouts: Displays a list of photo layouts, add or change the layout for the 
current page. 

7. Headline: Displays a list of different headline types. 
8. Store:  Displays kits that you can add from 

https://www.broderbund.com/catalogsearch/result/?q=royality+free 
 

 

 

 

http://www.printmasterpacks.com/
https://www.broderbund.com/catalogsearch/result/?q=royality+free
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9.4. Menus 
 

 

Fig 9.4: Menus 

1. PrintMaster 2020 menu (Windows only): About PrintMaster 2020– 
Copyright and version information.  
 

• Preferences: Change default program settings. 

• Services: Services for an operating system. 

• Hide PrintMaster 2020: Hide the PrintMaster 2020 program from 
view. 

• Hide Others: Hide all other open window applications from view.  

• Show All: Displays all hidden windows. 

• Quit PrintMaster 2020: Quits PrintMaster 2020. 
 

2. File menu: 
 

• New Project: Closes the current project, and opens the new project 
window. 

• Open Project: Closes the current project and display options for 
opening an existing project.  

• Recent Projects: Displays a list of recently opened projects. Click on a 
project to open it.  

• Closure Project: Closes the current project. 

• Save: Writes the project in its current state to disk. 

• Save As: Writes the project’s current state to disk in a custom 
location with a new name.  

• Save Photo Layout: Create a layout for later use, using the current 
photo and text boxes. 

• Delete Project: Delete a project permanently from your hard disk. 

• Rename Project: Rename the currently opened project. 

• Find Projects: Searches your computer for PrintMaster 2020 projects. 

• Print Setup: Opens the Page Setup window. 

• Print: Opens a print window for printing the project or individual 
pages. 

• Export: Opens a window for exporting the project or individual pages 
in various formats.  

• Exit: Closes the current project and quits PrintMaster 2020. 
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3. Edit menu: 
 

• Undo: Cancels the last operation. 

• Redo:  Reverses the effect of the undo operation. 

• Cut: Removes a page object from the page, but saves it in memory. 

• Copy: Saves a page object in memory so that it may be pasted to 
another location.  

• Paste: Adds the object from memory to the page (the object will be 
slightly offset). 

• Paste in Place: Add the object from memory to the page without an 
offset.  

• Clear: Permanently deletes a page object from the page. 

• Edit Object: Displays object size and info. It also lets you adjust the 
size. 

• Text Options: Update the case of selected text boxes. (UPPER, lower, 
Title, Sentence). 

• Delete Object: Removes the selected page object from the page. 

• Lock Object: Object cannot be edited or deleted. 

• Unlock All Page Objects: Unlocks all objects on the current page for 
editing. 

• Delete Shadow: Removes the shadow from the selected page object. 

• Delete Page: Removes the currently selected page from the project. 

• Find/Replace: Search and replace words in the project.  

• Project Properties: Displays the Project Properties dialog. 

• Change Project Size/Type: Change the current project to a different 
type and/or size.  

• Convert to Full Avery Sheet: Create a compatible Avery template. 

• Preferences: Opens the Preferences dialog to customize default 
program settings. 
 

4. Arrange menu: 
 

• Order: Adjusts the layer order of objects on the current project page.  

• Align: Brings objects into alignment with each other or the page. 

• Group: Fixes the position of objects red-eye one another.  

• Ungroup: Returns a group of objects to individual objects. 

• Select All: Selects all objects on the current page. 

• Select All Clip Art:  Same as Select All, except that it only selects clip 
art on the page.  

• Change Background Paper: Allows you to choose the background for 
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the current page.  

• Page Numbering: Add or customize page numbers in the project. 
 

5. Insert menu: 
 

• Add Page: Creates a new page in the project. 

• Add Other Template Pages: Add a set of select template pages. 

• Import from My Projects: Add pages from other projects to the 
current project. 

• Fast Fill Photos: Add a group of photos to empty photo boxes in the 
project automatically.  

• Add Photo: Choose a photo (JPG or PNG) to add to the current page. 

• Add Clip Art: Opens a window for selecting clip art to add to the 
current page.  

• Add Text: Places a text box on the current page. 

• Add Headline: Places a headline box on the current page. 

• Add Shape or Line: Displays a list of shapes that can be added to the 
current page.  
 

6. View menu: 
 

• View Project: Displays a preview of the way the project will appear in 
print. 

• Bleed Area: Displays a darkened area around the page that may be 
cut when printed.  

• Die lines: Hide/show cut and fold lines or instructions. 

• Show Guides: Allows you to add guides to your page for easy 
alignment.  

• Snap to Guides: Aligns objects to the guide when they are moved. 

• Snap to Page Objects: Aligns object edge with other object edges on-
page.  

• Rulers: Displays rulers along the top and left the side of the page. 

• Canvas Zoom: Opens a drop-down menu allowing you to zoom in or 
out.  

• Page Spreads-Displays two pages side by side for easier editing and 
overlap.  

• Previous Page: Selects and displays the previous page in the project. 

• Next Page: Selects and display the next page in the project. 

• Hide/Show Toolbar: Hides or displays the toolbar across the top of 
the interface.  

• Hide/Show Design tools: Hides or displays the design tools on the left 
of the interface.  
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• Hide/Show Page Thumbnails: Hides or displays the page thumbs on 
the bottom. 

• Hide/Show Resource Gallery: Hides or displays the gallery on the 
right of the interface.  

• Master Page: Master overlay page, items added to the master are 
displayed on all pages. 
 

7. Check the Project menu:  
 

• Check Page for Errors: Checks for problems on the current page and 
displays a list of results.  

• Check Project for Errors: Checks project for problems and displays a 
list of results. 

• Check Spelling: Checks project for spelling errors and suggests 
changes.  

• Lock Page: Page cannot be changed or deleted when locked. 
 

8. Share Project menu: 
 

• Print at Home: Opens the print wizard for printing to a connected 
home printer.  

• Export:  Prepares the project to be output to JPEG, PNG, PDF, or SVG 
files. 

• Order Photo Album:  Opens professionally print book upload 
window.  

• Order Calendar: Opens professionally print calendar upload window. 
 

9. Help menu: 
 

• Search: Quickly search the User Guide for keyword related topics. 

• PrintMaster 2020 Help: Opens the PrintMaster 2020 topics, and 
index help system.  

• Check for Updates: Check for and install the latest version update. 

• User Guide: Opens a PDF printable document for using PrintMaster. 

• Video Tutorials: Website with video tutorials and other helpful 
resources.  

• About PrintMaster 2020: Displays copyright and version information 
for PrintMaster 2020. 
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9.5. Colors 

 
Click on the color icon under design tools to adjust colors for selected objects.  

1. Palette: Select a color by clicking one of the color squares. Fig 
9.5.1 

 

Fig 9.5.1: Palette 

2. Combos: Select a color for suggested complementary color 
combinations. Fig 9.5.2 

 

 

Fig 9.5.2: Combos 

 

3. Swatches: A range of colors, select a color by clicking one of the 
color squares. 
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4. HSV: (Hue, Saturation, and Value). Fig 9.5.4 

 

Fig 9.5.4: HSV 

5. HSL: (Hue, Saturation, and Lightness). Fig 9.5.5: 
 

• Add or remove white, black, and gray, as well as lighten or 
darken a color. 

• Move the slider up or down to choose the desired hue. 

• Click‐and‐drag in large color box to adjust the white, black, 
and grey. 

• You may also type, click on the arrows, or drag the sliders to 
adjust the values. 

 

Fig 9.5.5: HSL 

 

6. RGB: (Red, Green, and Blue) Fig 9.5.6: 
 

• A standard method of choosing colors based on red, green, 
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and blue values. 

• Drag the red, green, and blue sliders to adjust the amount of 
each color. 

• 0 is absence, and 255 is the maximum color value in the alpha 
slider. 

• Color code is displayed for the values selected; you may also 
enter a color code. 

 

Fig 9.5.6: RGB 

7. CMYK: (Cyan, Magenta, Yellow, and Key Black) Ink colors used 
more commonly in printing. Fig 9.5.7 

• Drag the cyan, magenta, yellow, and key sliders to adjust the 
amount of each color. 

• 0 is absence, and 255 is the maximum color value in the alpha 
slider. 

 

Fig 9.5.7: CMYK 

 
8. Favorites: Store up to 40 of your favorite colors. Fig 9.5.8 

• To save a color to Favorites, pick a color in any tab then click 
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Add to Favorites. 

• Once 40 slots are filled, the oldest color will be removed 
when you add a new color. 

• To remove a favorite color, select one, then click the remove 
favorite button. 

 

Fig 9.5.8: Favorites 

9. Gradient: Gradient colors can be used with backgrounds, shapes, 
and headlines. Fig 9.5.9. 

 

 

Fig 9.5.9: Gradient 

10. Click one of the 2 small color squares above the gradient bar to 
select a gradient. 

11. Then click on the larger color square to set the color for the 
selected gradient. 

• Drag the small circles in the preview area to manipulate the 
gradient. 
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• Clicking in the preview area moves the nearest circle to the 
position of your cursor. 

• Add color places an additional gradient color in the top 
gradient bar. 

• The style drop-down lets you choose between linear and 
radial gradients. 

• You may change the pattern of the gradient by selecting 
reflect or repeat. 

• Selecting reverse swaps, the gradient color direction. 
 

9.6. Toolbar 

The main toolbar contains the most common program functions. 

 

 

Fig 9.6: Toolbar 

9.6.1. Icon Descriptions:  

 
• New Project: Opens the new project window. 

• Open a Project: Open an existing project. 

• Save: Saves the project in its current state to disk. 

• Import: Import pages from another project. 

• Add New Page: Opens the Add New Page dialog. 

• Layers: Displays the options for adjusting the object layer 
position. 

• Page Guides: Display a guide to assist with accuracy when 
moving objects. 

• Align Objects: Displays the options for changing the alignment 
of objects. 

• Cut: Removes a selected object to the clipboard to be pasted 
in another location. 

• Copy: Copies a selected object to the clipboard to be pasted 
in another location. 

• Paste: Applies the page object stored in the clipboard to the 
current page. 

• Paste in Place: Same as Paste, except that the pasted object 
does not paste offset. 

• Undo: Cancels the last operation. 

• Redo: Restores the “undone” operation. 

• Convert Avery Template: Creates the Avery template project 
from a single item. 
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• Add Background: Add a background. 

• Add Photo: Opens a window for importing a photo (jpg or 
png). 

• Add Text: Creates a new text box on the page. 

• Add Headline: Creates a new headline box on the page. 

• Add Clip Art: Opens a window for adding clip art to the 
current page. 

• Add Shape or Line: Opens a window for choosing a shape. 

• Preview: Presents a preview of the way the project will 
appear in print. 

• Check Spelling: Checks the spelling on all pages and suggests 
changes. 

• Share: Share your pages as JPG, PNG, or PDF. 

• Ideas: Opens a site with video tutorials, as well as other 
helpful resources. 

• Help: Opens the PrintMaster 2020 help topics. 
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9.7. Design Tools 

  

Fig 9.7: Design Tools 

 

• Backgrounds: Allows you to add and edit background papers. 

• Photos: Add and edit images. 

• Text: Add and edit text, and address fields. 

• Headlines: Add and edit headlines 

• Calendar: Add and edit calendar months or years. 

• Clip Art: Add and edit clip art to enhance the layout 
composition. 

• Shapes and Lines: Add, edit, and create custom shapes. 

• Paint: Add a paint area to the page, draw, edit, and erase. 

• Project: See elements used, preview, error check, and 
manage page guides. 

• Share Project: Options for printing at home, exporting, and 
ordering. 

 

 



P a g e  | 36 

 

 

10. USING PrintMaster 2020 
 

10.1. Starting a Project 

When you first open PrintMaster 2020 project options are displayed. Fig 10.1 
 

 

Fig 10.1: Starting a Project 

1. Template: Create a project from a pre‐designed layout. 

2. Create from Scratch: Create a project from a blank canvas with a custom size.  

• Open: Open an existing PrintMaster 2020 project. 

• Recent: Click on one of 5 the most recent projects at the bottom to open it. 

 

Return to this screen when opening the software, or by going to File > New. 

 

10.2. Create from Template 

1. Create a project from a pre‐designed layout. 

2. Select a project type on the left. 

3. Next, select a desired template in the preview area then click Finish. Fig 10.2 
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Fig 10.2: Create from Template 

Tabs at the top sort project types: 
 

• All Categories: All projects, organized by category and subcategory 

• Print at Home: All projects, grouped by type 

• Print Professionally: Projects that can be printed professionally 

• Matching Sets: Projects with coordinating design themes 

• Search for a project by typing keywords into the Search field below 
the project type. 

• Drag the Preview Size slider at the bottom to display a larger preview. 

• You may need to scroll down to see all of the choices available. 

• Click on the plus symbol or arrow next to a type to display subcategories 

 

10.3. Design Your Own 

 
Create a project from a blank canvas with a custom or selected size. Fig 10.3 
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Fig 10.3: Design Your Own 

1. Select a type from the Type drop-down menu. 

2. Select a suggested size or enter your own, then click OK. 

• Some project types (business cards, mailing labels, etc.) allow many similar 
items on a page per print.  

• If the project type supports it, the Horiz. and Vert. Gap settings can be 
adjusted to set the amount of space between each item when printed. 

10.4. Saving Projects 

1. Save your project often. This will ensure that you don’t lose work. 

2. To save your project go to the File menu > Save. 

3. You may also click the Save icon in the toolbar to save your project. 

4. Pressing the key command (Control+S) will also save. 

Note: The save icon will be disabled if all changes have been saved. Fig 10.4 (a) 

 

Fig 10.4 (a): Saving Projects 
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5. When first saving a project, you may enter a name, and choose where it saves. 

6. Additionally, when closing or opening another project a save prompt is 
displayed. Fig 10.4 (b) 

 

 

Fig 10.4 (b): Saving Projects 

 

To make a copy and set a new save location for projects go to File menu > Save As. 

10.5. Opening a Project 

 

To open an existing project, do one of the following: Fig 10.5 (a) 

1. Go to the File menu > Recent Projects, and select your project from the list. 

 
Fig 10.5 (a).: Opening a Project 

 

3. Go to the File menu > Open Project, select your project then click open. 
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Fig 10.5 (b): Opening a Project 

 

4. Re-open PrintMaster 2020 and click on a Recent project under the creative 
options. 

 

10.6. Project Pages 

 
                   You can add, import, rearrange, and remove pages from your project. 

10.6.1. Adding a Page: 

1. Go to the Insert menu > Add Page, or click the Add Page icon. 
2. In the Add, Page window select a blank page or layout, then click Ok. Fig 10.6.1 

 

Fig 10.6.1.: Adding a Page 
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10.6.2. Delete a Page: 

1. Select the page you wish to remove in your project. 
2. Go to the Edit menu > Delete Page. 

10.6.3. Delete Multiple Pages: 

1. Hold the Shift key and select multiple pages thumbnails. 
2. Go to the Edit menu > Delete Page. The selected pages will be removed. Page 

Order 

10.6.4. To Reorder Pages in a Project: 

1. Select a page thumbnail then drag the page right or left and drop it in a new 
position. Fig 10.6.4 

2. As you move the page the other pages will be automatically rearranged and 
renumber. 

 
Fig 10.6.4: Rearrange Pages 

10.6.5. Importing Pages:  

1. Import pages from an existing project into the current project. 
2. Go to the Insert menu > Import from My Projects. 
3. In the new window click on the folder icon at the top right. 
4. Open the project you want to import pages from. 
5. Select a page from the left column you wish to add click Import. Fig 10.6.5 

 

 
Fig 10.6.5: Importing Pages 
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6. To select multiple pages in sequence, hold the Shift key while clicking on a 
page.   

7. You may also import objects from other pages using the objects column. 
8. When finished importing, click the Close button. 

 

10.7. Photo Layouts 
1. Layouts are used as a guideline for a quick photo and text placement. 
2. Click on the Layout icon in the Resource Gallery (right side). 
3. Double-click or drag and drop one of the available layouts to apply it to the 

page. 
 

Note: Choosing a layout with fewer photos than the current page, will remove photos from the 

page. Fig 10.7 

 
Fig 10.7: Photo Layouts 

4. You can save created layouts for later use by going to the File menu > Save 
Photo Layout. 

 

10.8. Working with Page Objects 

 
         A Page Object is anything that you place on a page, such as photos, shapes, text, etc. 

10.8.1. Selecting Objects: 

1. Left-click an object to select it. 

2. A Light gray box with small square handles will appear at the object’s edges. 

3. Dragging the corner handles resizes the object proportionally. 

4. Dragging side handles will stretch or reduce an individual side. 



P a g e  | 43 

 

 

5. Corner handles are also used to rotate objects when your cursor is a curved arrow. 

6. You may select multiple objects by holding the Shift key. 

7. You may deselect a single object by clicking on it again while holding Shift. 

8. You may select all objects by going to the Arrange menu > Select All. 
 

 
Fig 10.8.1.: Selecting Objects 

 

10.8.2. Moving Objects: 

1. Left-click and hold on the selected object. 

2. Drag from the center of the object to adjust the position. 

3. After you have it positioned let go of the mouse button. 

4. Moving multiple objects simultaneously is the same. Hold shift to select 
multiple objects then drag from the center of a selected object to move them. 

10.8.3. Aligning Objects: 

1. Rulers ‐ Rulers can be helpful with alignment, positioning, and trim or bleed 
areas. 

2. To enable rulers, go to the View menu > Rulers. (or click on the ruler icon) 
3. To adjust the ruler units (inch, cm, pixel) go to Preferences > Ruler. 

10.8.4. Page Guides: 

1. Page Guides ensure accuracy when aligning objects use page guides. 
2. To use Guides, enable Rulers View > Rulers. (or click the Ruler icon) 
3. Enable Guides from the View menu > Show Guides. (or click the Guides icon) 
4. Position your cursor over the top or side ruler, then left-click to place a guide. 
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Fig 10.18.4: Page Guides 

 

5. You may also add multiple guides by left-clicking other locations along the 
ruler. 

6. To remove a guide drag it off of the ruler bar, or disable it from View > Show 
Guides. 

7. Snap to Guide aligns the edge of objects with the closest guide when moved. 
Guides will not appear in the final project output. (print, jpg, etc.) 
 

10.8.5. Align Menu  

1. Another way to align objects is with the Align menu item. 
2. After selecting one or more objects, go to the Arrange menu > Align. 
3. Choose from the list of available alignment options in the drop-down: 
4. Top: Aligns all selected objects to the topmost object on the page. 
5. Middle: Lines up the vertical middle of each selected object. 
6. Bottom: Aligns all selected objects to the bottommost object on the page. 
7. Left: Aligns all selected objects to the leftmost object on the page. 
8. Center: Lines up the horizontal center of each selected object. 
9. Right: Aligns all selected objects to the rightmost object on the page. 
10. Center Vertical on Page: Places selected objects in the vertical center of the 

page. 
11. Center Horizontal on Page: Places objects in the horizontal center of the page. 
12. Space Evenly: Horizontal: Arranges the currently selected objects so that they 

all have the same amount of horizontal space between them. 
13. Space Evenly: Vertical: Arranges the currently selected objects so that they all 

have the same amount of vertical space between them. 
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Fig 10.8.5: Align Menu 

 

10.8.6. Grouping Objects: 

1. Grouping objects will fix the object's position in relation to grouped objects. 
This makes it easy to move, rotate, and resize multiple objects at once. 

2. To group, objects hold shift and select more than one object on the page. 
3. Then go to the Arrange menu > Group. 
4. Move, resize, and rotate grouped objects similar to individual objects. 

10.8.7. Ungroup Objects: 

To ungroup the selected group, go to the Arrange menu > Ungroup. 

 

 

Fig 10.8.7: Ungroup Objects 
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10.8.8. Cut, Copy, and Paste: 

           Allow you to remove, duplicate, or move objects between pages, 

1. Cut: 

• To cut the selected object, go to the Edit menu > Cut. (or. Select the Cut icon) 

• The cut object(s) is now available for pasting anywhere in the project. 
 

2. Copy: 

• To copy the selected object, go to the Edit menu > Copy. (or select the Copy 
icon) 

• The copied object(s) is now available for pasting anywhere in your project. 
 

3. Paste: 

• After cutting or copying an object, select the page where the object(s) should 
be pasted. 

• Go to the Edit menu > Paste. (or select the Paste icon) 

• To paste objects without an offset, go to the Edit menu > Paste in Place. 
 

 

 

Fig 10.8.8: Cut, Copy and Paste 
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10.8.9. Deleting Objects: 

1. Select the object by clicking on it. 
2. Do one of the following: 
3. Press the Delete key on your keyboard. 
4. Go to the Edit menu > Delete. 
5. Right-click the object and choose Delete. 

 

 

Fig 10.8.9: Deleting Objects 

 

10.8.10. Layers:  
 

1. Each object is on its own layer. Layer order determines which objects display 
on top of other objects. 

2. The most recently added object will have a higher layer order and display on 
top.  

3. All objects will display on top of the background image. 
To adjust layers: 
 
a) Select the object to adjust. 
b) Go to the Arrange menu > Order and select the desired action. 
c) Bring to Front – Places the object on top of all other objects. 
d) Send to Back – Places the object behind all other objects. 
e) Bring Forward – Moves the object up one layer. 
f) Send Backward – Pushes the object back one layer. 
g) Right-clicking on an object also allows you to adjust the layer. 
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Fig 10.8.10: Layers 

 

10.8.11. Layers Gallery 
 

1. Another way to view and sort object layers is by using the Layers gallery. 
2. Select the layers icon in the gallery panel. 
3. Drag the object up or down in the layers panel to adjust the layer order on the 

page. 
4. You may select an object by double‐clicking on an object layer. 
5. Right‐clicking on an object layer allows you to delete it or bring up edit 

options. 
 

 

Fig 10.8.11: Layers Gallery 
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10.9. Backgrounds 
1. The background serves as the bottom layer of a page. Icon Descriptions. 
2. Add: Select a background paper to add your page. Color – Select a color to 

apply to as your background. Black – Set the background color to black. 
3. White: Set the background color to white. 
4. Recolor: Recolor the currently applied background image. Effects – Apply an 

effect to the current background image. 
5. Tile: Makes a smaller repeating tile pattern of the current background image. 
6. Custom: Select an image file from your computer to use as a background. 
7. Mirror: Flip the background horizontally. 
8. Flip: Flip the background vertically. 
9. Left: Rotate the background image 90 degrees to the left. Right – Rotate the 

background image 90 degrees to the right.  
10. Remove- Deletes the current background. 
11. Apply: Applies the current background to all other pages in the project. 
12. Opacity: Drag the slider left or right to increase or decrease the background 

transparency. 
 

 

Fig 10.9: Backgrounds 

 

13. You can set the background to be a color, paper, or image. 
14. Projects start with a transparent checkered background, if you add objects to 

your page and export it as a PNG the exported image will only display the 
page objects added because the background is transparent. 

15. If you export your page as JPG or PDF and have not set a background it will 
default to a white background. 
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10.9.1. Adding Backgrounds 

1. Select a page. 
2. Open the Backgrounds tab in the Design Tools panel. 
3. Click on the Add icon. 
4. Choose a paper by selecting a category, then select one of the preview images 

and click Ok. 
5. This will apply the selected background to the current page. 
6. Adding a background as a photo object allows you size, position, and layer the 

background just like a photo. 
7. You can also search your desired background by using the search option 

 

 

Fig 10.9.1: Adding Backgrounds 

 

 

10.9.2. Adding Custom Backgrounds 

1. Select a page. 
2. Open the Backgrounds tab in the Design Tools panel. 
3. Click on the Custom icon. 
4. Select an image from your computer then click Ok. 

 

10.9.3. Add a Background Color 

1. Select a Page. 
2. Open the Backgrounds tab in the Design Tools panel. 
3. Click on the Color icon. 
4. Use the color palette to select a color, then click Ok. 
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Fig 10.9.3: Adding a Background Color 

 

10.10. Photos 

 

Fig 10.10: Photos 
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10.10.1. Icon Descriptions: 

1. Add:  Add a selected photo to your page. 
2. Box: Add an empty photo box to your page that can be filled with a photo 

later. 
3. Border: Add a border around the selected photo. 
4. Shadow: Add a shadow to the selected photo. 
5. Effects: Apply effects such as black and white, sepia, etc. to the selected 

photo. 
6. Recolor: Recolor the selected image. 
7. Rip: Rip the edge (s) of a selected photo. 
8. Shape: Convert the selected image from a box to a shape. 
9. Crop: Crop unwanted portions of an image out of the selected photo. 
10. Nudge: Slightly move the displayed area of a zoomed or cropped an image. 
11. Out: Zoom out the displayed on the selected photo. 
12. In:  Zoom in on the displayed area of the selected photo. 
13. Mirror: Flip the image horizontally on the page. 
14. Flip: Flip the image vertically on the page. 
15. Left: Rotate the image left 90 degrees. 
16. Right: Rotate the image right 90 degrees. 
17. Remove: Deletes the photo from the page. 
18. Edit: Displays photo info and allows you to adjust the photo size and position. 
19. Red: Remove redeye from a selected photo. 
20. Replace: Swap the selected image with a different photo. 
21. Opacity: Drag the slider left or right to increase or reduce the photo's 

transparency. 
22. Rotation: Drag the slider left or right to apply a rotation. 

 

10.10.2. Photo Recommendations: 

1. Format: JPG or PDF. 
2. Resolution: Roughly 300DPI (dots per inch) or higher recommended for 

printing.  
3. Ratio: 4x4 inches (1200x1200 pixels) or larger for printing.  
4. Background or full: Page images should be 12x12 (3600x3600) or larger. 
5. File Size: Roughly 10MB or less in file size. Larger file sizes can have trouble 

rendering. 
6. Color Mode: RGB, (red, green, blue). 
7. Clip Art: Save as JPG, and add as custom Clip Art to preserve transparency. 

 
10.10.3. Adding Photos: 

1. There are multiple methods for adding a photo to a page: Add Icon. 
2. Select a page. 
3. Open the Photos tab. 
4. Click on the Add icon. 
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5. Select an image from your computer and click Ok. 
 

10.10.4. Gallery: 

1. Select a page. 
2. Select the Photo icon in the Resource Gallery. 
3. Double: click or drag and drop an image from the gallery list onto your page. 

 

 

Fig 10.10.4: Gallery 

 

10.10.5. Photo Box:  

1. Add or use an existing photo box on the page. 

2. Double: click on the empty box. 
3. Select an image from your computer and click Ok. 
4. Drag and Drop: You can drop images onto your page from a folder on your 

computer. 
5.  Copy and Paste: You may copy and paste image files onto your page as well. 
6. Photo Tiling: Allows you to fill multiple photo boxes with a single image. 
7. Open the Photos tab under Design Tools. 
8. Click on the Add Photo Box icon to place an empty box on your page. 
9. Repeat this process, size, and position multiple boxes throughout the page. 
10.While holding the shift key, select multiple boxes with a left-click. 
11.Once all the boxes are selected go to the Arrange menu > Group. 
12.Open the photos tab in the Resource Gallery. 
13.Drag and drop an image from the gallery onto the grouped boxes 
14.The image will fill the space of the grouped boxes leaving space between boxes. 

 

 



P a g e  | 54 

 

 

 

Fig 10.10.5.: Photo Box 

10.10.6. Borders:  

1. You may add a border or frame around a photo. 
2. Select a photo and click on the border icon to display the border dialog. 
3.   Drag the Size slider to change the size of the border. (pixels)  Click Change 

to choose a color for the border. 
4.   Toggle the checkboxes to apply the border settings to all photos on the page 

or project.  
5.  Click OK to apply. 

 

10.10.7. Shadows: 

1. Add a shadow to a photo to give it depth and make it stand out on the page. 
2. Select a photo and click on the shadow icon to display the shadow dialog. 

 

Fig 10.10.7(a) - Shadows 
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3. Use the Opacity slider to affect how dark or light the shadow is. 
4. Use the Blur slider to increase or decrease the sharpness of the shadow’s 

edge. 
5. Click Change to choose the shadow’s color. 
6. Use the arrow keys to adjust the shadow position or drag the shadow in the 

preview.  
7. Toggle the checkboxes to apply the shadow settings to all images. 
8. Reset to Default will clear the current settings. 
9.  Save as Default will save the current settings as the default.  
10. Click OK to apply the shadow to the selected photo. 
11. Crop: Allows you to display the desired section of a photo. 
12. With a photo selected, click on the Crop icon. 
13. If the photo is already cropped, it will show the current crop area. 
14. If the photo does not have a currently defined crop area, position your cursor 

in the preview area, then left: click and drag a selection box to define the crop 
area. 

15. Drag from the small grey box handles to adjust the size of the crop area. 
16. To start over, or to display the entire photo, click the Clear Crop button. 
17. When you are satisfied with your crop area selection, click on the OK button. 
18. The grayed areas of the photo will not be shown on the page. 

 

 

Fig 10.10.7 (b): Shadows 

 

10.10.8. Nudge: 

 

This tool allows you to adjust the position of the photo within the crop area without reopening 

the Crop Photo window. Click on an arrow to nudge the photo in the direction of the arrow. 
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Note: This tool will have no effect if the photo is not cropped. 

10.10.9. Remove Red Eye: 

 

            Red Eye causes the irises of a person’s eye to appear red in a photo. 

With a photo selected, click on the Remove Red Eye icon. 

 

 

Fig 10.10.9 (a):  Remove Red Eye 

Drag a rectangle over the affected area. 
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Fig 10.10.9 (b):  Remove Red Eye 

 
 

 

1. A light gray rectangle will indicate the area you have selected 
2. Increase the Red Sensitivity slider to replace more shades of red. 
3. Round Shape Filter box will limit red replacement to circular areas. 
4. Reset Photo returns the photo to its original state (before any red-eye reduction). 
5. After choosing your settings, click on the Remove Red button. 

 

 
Fig 10.10.9 (c):  Remove Red Eye 

10.10.10. Photo Effects: 

 

          Allow you to apply different effects to a selected photo. 

1. Black & White: Transforms a color photo into a black and white photo. 
2. Sepia:  Applies a brown and white coloration to the photo. 
3. Blue: Applies blue coloration to the photo. 
4. Red: Applies red coloration to the photo. 
5. Brighten: Brightens the image. 
6. Darken: Darken the image. 
7. Mirror: Flip the photo around horizontally. 
8. Flip: Flip the photo vertically. 
9. Blur: Softens the focus, reducing the definition of the photo. 
10.Sharpen - Increases the focus, or definition, of the photo. 
11.Negative: Reverses the colors in a photo, as if viewing a film/photo negative. 
12.Gamma Correction: Changes the brightness values of the gray tones without 

dramatically altering the shadows and highlights. 
13.Emboss: Makes the photo look like foil has been placed over the photo, sculpted 

to the photo’s contours, and then colorized. 
14.Sketch: Simulates a pencil drawing of the photo. 
15.Impressionist Painting: Gives the photo an artistic, brushed look. 
16.Fish Eye: Distorts photos to make the middle portion of the photo appear larger. 
17.Effect Amount: Drag the slider left or right to apply more or less of the effect 
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Fig 10.10.10: Photo Effects 

10.10.11. Photo Edit:  

It allows you to make adjustments to the size and location of the photo. Fig 10.10.11 

1. Enter a number or click on the arrows to adjust the settings in each field. 
2. X – Changes the horizontal position of the selected object. 
3. Y – Changes the vertical position of the selected object. 
4. W (Width) – Changes the width of the selected object. 
5. H (Height) – Changes the height of the selected object. 
6.  Keep Proportions automatically adjust the height as you change the width or 

height to keep the photo from becoming distorted. 
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Fig 10.10.11. Photo Edit 

 
 

10.11. Text 
The text allows you to add captions, and information on your page. Icon Descriptions. 

1. Add – Adds a text box to your page. 
2. Case – Updates case on a selected text box. (UPPER, lower, Title, Sentence.)  
3. Curve – Curve your text around or inside a square or circle shape. 
4. Shadow – Adds a shadow to the selected text to give it depth.  
5. Color – Sets a desired color for the selected text. 
6. Match – Match the color of other elements on the page.  
7. Black – Changes the selected text color to black. 
8. White–Changes the selected text color to white.  
9. Mirror – Flips the text horizontally. Flip – Flips the text vertically. 
10. Left – Rotates the text left 90 degrees. 
11. Right – Rotates the text right 90 degrees. 
12. Remove – Deletes the selected text box from the page. 
13. Edit – Enter and exit the typing mode, so that you can enter new text, or adjust 

the position. 
14. Padding – Increase or decrease the distance text is placed from the edge of the 

box.  
15. Border – Add a border around the selected text box. 
16. Address – Brings up your address book contact list.  
17. Field – Select a specific field from your address book. 
18. Insert – Allows you to insert the selected filed into a text box.  
19. Font – Loads a drop-down menu of available fonts. 
20. Size – Set the desired size of the selected text from the drop-down menu.  
21. Spacing – Adjust the space between lines. (1 – 3) 
22. Tracking – Adjust the space between individual letters. 
23. Horizontal Alignment – Set text justification to Left, Center, Right, or Full.  
24. Vertical Alignment – Set text justification to Top, Middle, or Bottom. 
25. Style – Select B (Bold), U (Underline), I (Italicize), or (Bullet) to apply the style. 
26. Opacity – Drag the slider left or right to increase or reduce the transparency. 
27. Rotation – Drag the slider left or right to apply a rotation. 

 
10.11.1. Adding Text: 

 

1. To add text, open the Text tab under design tools, and click on the Add icon. 
2. A text box will appear in the middle of the page. 
3. Type your text in the text box. 
4. Use the options in the text panel to change the size, font, or style of highlight text. 
5. Drag from the handles (small grey boxes) on the edge of the box to adjust its size. 
6. De-select the box, then drag from the center of the box to adjust the position. 
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Fig 10.11.1: Adding Text 

 

10.11.2. Edit Text: 

 

1. To enter edit mode (allows typing) double-click on the text box. 
2. To exit edit mode (allows positioning) de-select the box by clicking off the page. 
3. You can also change the size, underline, bold or italic a single alphabet in the 

whole word or line in Text-box 
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Fig 10.11.2: Edit Text 

 

 

10.11.3. Text Font: 

 

1. Set All Project Text Fonts ‐ Apply fonts and styles to all text boxes in a project. 
2. Go to the Edit menu > Text Options > Set All Project Text Fonts. 
3. In the Text Style Editor, dialog select your new font, size, style & color. 

 

Fig 10.11.3: Text Font 

 

10.11.4. Save Text: 

Click Ok to apply the change to all text within your project. 
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Fig 10.11.4: Save Text 

 

 

10.11.5. Text Case Tools: 

 

1. Change text to UPPER, lower, Sentence, or Title case. 
2. Select a text box, then go to the Edit menu > Text Options. 

 

Fig 10.11.5: Text Case Tools 

 

10.11.6. Font Types: 

1. Recently Used Fonts and Type to Select Fonts 
2. The font drops down menu supports 5 recent fonts that will automatically appear 

at the top of the list as you apply different fonts to Text objects. 
3. You can also click the drop-down and start typing the name of the font, the menu 

with a jump to the font with the same name, this saves time instead of having to 
manually scroll large font lists. 
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Fig 10.11.6: Font Types 

 

 

10.12. Address Book and Mail Merge 

To use the Address Book and Mail Merge feature in PrintMaster 2020 you 
can create a contact list from scratch or import an existing contact list in 
.csv file format.  

To create an Address Book from scratch, follow these steps. 

1. Select the project type you wish to personalize with names or addresses 

2. In the left- hand Design Tools navigation select Text 

3. From the Text tools option select Address 

4. You should now see the Address Book. Select Add to create a New Contact 

5. Fill out the New Contact details and select Save. 

6. To create another contact select Add again. 

7.  To change a contact select Edit, to delete a contact select Delete. 

 

Fig 10.12: Address Book and Mail Merge 

 

10.12.1. Import an Address Book 

1. To import an Address Book from an existing .csv file format follow these steps. 

2. Select the project type you wish to personalize with names or addresses 

3. In the left-hand Design Tools navigation select Text 

4. From the Text tools option select Address 

5. You should now see the Address Book. Select Import to import your contacts 
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6. Select Browse to find the .csv file you would like to import 

7. Open the .csv file and you will see the Import Contacts dialogue 

8. If your .csv file contains a Header Row with names or other data designations you 
can have that row removed from the import process by changing the Header Rows 
field 

9. Next, you must assign each of the columns a name. On the right side, you can 
assign each column to a matching address book field by using the pull-down menu 
option under the Name column. 

10. Assign each column you wish to import into PrintMaster 2020 a name and select 
Import. 

 
10.12.2. Add Contact Details: 

1. To place contact details into a project, follow these steps: 

2. In the left- hand Design Tools navigation select Text 

3. From the Text tools option select Address 

4. You should now see the Address Book 

5. From the Address Book select the Contacts that you would like to include in your 
project 

6. Next, add a text box to the project by selecting the Add option from the Text tools 
option 

7. To add a name and address from your Address Book select the First Name from 
the Field next to the Address button. 

8. With the text cursor in the text box where you want to place the First Name, select 
the Insert button. Continue this process to add the Last Name, Address 1 and 
remaining address fields. 

9. You may need to increase the font size to make it easier to read. Select the Size 

10. Option under the font name and choose a larger font size. 

 
10.12.3. Print Preview 

1. Print Preview your project to make sure all of the Fields are properly displayed by 
selecting the File / Print at Home option and Preview. 

2. When asked to apply mail merge contacts to your document select Yes 
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Fig 10.12.3. Address Book and Mail Merge 

10.13. Headlines 

Headlines allow you to customize text further with image fill, stroke, shadows, etc. Icon 
Descriptions. 

1. Add – Adds a headline box to your page. 

2. Font – Loads a drop-down menu of available fonts. 

3. Size – Set the desired size of the selected headline from the drop-down menu.  

4. Spacing – Adjust the space between lines. (1 – 3) 

5. Tracking–Adjust the space between individual letters. Style – Select B (Bold) or I 
(Italicize) to apply the style. 

6. Opacity – Drag the slider left or right to increase or reduce the transparency. 

7. Rotation – Drag the slider left or right to apply a rotation. 
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Fig 10.13: Headlines 

 

10.13.1. Adding Headlines 

1. To add a headline to a page, open the Headlines tab and click on the Add icon. 

2. A headline box will appear in the middle of the page. 

3. Type your headline, the headline box will update with what is typed. 

4. Drag from the center of the box to adjust the position. 

5. Drag from the handles (small grey boxes) to adjust the size of the box. 

6. Please note that the text will stretch to fit the headline box and will adjust the font 
size. To enter edit mode (allows typing) double- click on the headline box. 

7. You may size and position headlines on the page while in edit mode. 

 

 

Fig 10.13.1: Adding Headlines 

 

10.13.2. Fill Tab 

1. Fill the characters in a headline: Color, Gradient, Image, and Texture.   

2. Toggle the Enable checkbox to apply or clear the fill. 

3. Select an option from the File Type drop-down. 

4. Solid Color – Click on the Change Color square to select a color for the fill. 

5. Gradient Color- Click on the Gradient Color square to change the gradient 
settings. 

6. Image – Click on the Change icon to choose an image file to fill the headline. 

7. Double-click on the headline to adjust the image’s position in the headline. 

8. Texture – Click on one of the Texture Options to fill the headline with that texture.  
Drag the Fill Opacity slider to increase or decrease the transparency of the fill. 
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Fig 10.13.2: Fill Tab 

10.13.3. Stroke Tab 

1. A stroke is a colored border around the headline. 

2. Toggle the Enable checkbox to apply or clear the stroke.  Select an option from the Stroke 
Style drop-down. 

3. Solid Color – Click on the Change Color square to select a color for the stroke. 

4. Gradient Color- Click on the Gradient Color square to change the gradient settings. 

5. Neon – Click on the Edge Color icon to change the color of the outside of the glow. Click 
on the Center Color icon to change the color of the middle. 

6. Glow – Click on the Glow Color icon to change the color of the glow effect.  

a. Drag the Stroke Width slider to increase or decrease the thickness of the stroke. 

b. Drag the Stroke Opacity slider to increase or decrease the transparency of the 
stroke. 
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Fig 10.13.3: Stroke Tab 

 

10.13.4. Shadow Tab 

 

1. Toggle the Enable checkbox to apply or clear the shadow. 

2. Click on the Shadow Color button to choose the shadow’s color. 

3. The pixel offset values (X and Y) values determine how far the shadow stretches from the 
headline, and to which direction. Enter a value or use the arrows to adjust the offset. 

4. Use the Shadow Blur slider to increase or decrease the sharpness of the shadow’s edge.  
Drag the Shadow Opacity slider to increase or decrease the shadow transparency. 

 

 

Fig 10.13.4.: Shadow Tab 

 

10.13.5. Shape Tab 

1. The Shape Options allow you to bend the headline to the shape of your choosing.  

2. Toggle the Enable checkbox to apply or clear the shape. 

3. Select Shape Type - Depending on your selection, you may see the options below. 

4. Arc Options – Drag the Angle slider to intensify the curve of the arc or flatten it 
out. 

5. Shear Options – Drag the X Magnitude slider to set the horizontal slant of the 
shear. Drag the Y Magnitude slider to set the vertical slant of the shear. 

6. Wave Options – Drag the slider to increase or decrease the wave effect. 
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Fig 10.13.5.: Shape Tab 

10.13.6. 3D Tab 

1. The 3D effects give the headline the appearance of thickness or depth.  Toggle the 
Enable checkbox to apply or clear the 3D settings. 

2. Click on the Change Edge Color button to choose the effect’s color. 

3. Drag the Horizontal and Vertical sliders to determine the amount of the 3D effect. 

4. Horizontal will increase or decrease the horizontal thickness of the 3D edge.  

5. Vertical will increase or decrease the vertical thickness of the 3D edge. 

 

 

Fig 10.13.6: 3D Tab 
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10.14. Calendar 

The calendar allows you to see and change month or year on the calendar page.  

Icon Descriptions: 

a) Month – Add a calendar month to your page. Year – Add a calendar year to 
your page. 

b) Edit – Adjust the header, line, and date appearance of the selected calendar. 
Remove – Delete the selected calendar from the page. 

c) Month – Set a desired month for the selected calendar. Year – Set a desired 
year for the selected calendar. 

d) Header – Toggle the header box to show or hide the month or year header. 
Lines – Toggle the lines box to show or hide the separating grid lines. 

e) Numbers – Toggle the numbers box to show or hide the numbered dates. 

f) Apply settings to All Calendars – Applies the current calendar appearance to all 
calendars. 

 

 

Fig 10.14: Calendar 

 

10.14.1. Add Calendar to A Page: 

1. Open the Calendar tab and click on the Month icon. 

2. The calendar grid will appear in the middle of the page. 

3. Drag from the center of the calendar to adjust the position. 

4. Drag from the handles to adjust the size. 

5. To enter an exact size right-click on the calendar and choose Edit Object. 
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10.14.2. Calendar Settings: 

You can set your calendar by selecting the left side tabs 

1. Toggle the Dates checkbox to hide or show the dates on the selected calendar. 

2. Toggle the outline dates checkbox to hide or show the outline dates on the 
selected calendar. Change the month by using a dropdown menu. 

3. Change the year by using a dropdown menu. 

4. Font – Set font for the header or weekday names. 

5. Size – Set the font size for the header or weekday names. 

6. You can change the color of month and year by selecting Month fonts from the 
left tab. You can change the day number in the selected calendar by choosing day 
fonts. 

7. You can change the outline dates by choosing the Display option. You can also 
change the alignment of dates in the calendar from this option 

 

 

Fig 10.14.2.: Calendar Setting 

 
10.14.3. Line Settings: 

 

Change the outline color by choosing display options 
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Fig 10.14.3: Line Setting 

10.14.4. Numbers Settings: 

 

1. Font – Set a font style by using the dropdown. 

2. Size – Set a size for the numbers by using the + or, click on the drop-down button 
to change the text color. 

 

 

 

Fig 10.14.4: Number Setting 

 

10.15. Clip Art 

The clip art is a collection of graphic objects that are used for decoration on a page. 

 
10.15.1. Icon Descriptions: 

1. Add – Add a selected Clip Art to your page. 
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2. Recolor – Recolor the selected Clip Art. 

3. Crop – Crop unwanted portions of a Clip Art image. 

4. Shadow – Add a shadow to the selected photo. 

5. Mirror – Flip the image horizontally on the page. 

6. Flip – Flip the image vertically on the page. 

7. Left – Rotate the image left 90 degrees. 

8. Right – Rotate the image right 90 degrees. 

9. Remove – Deletes the image from the page. 

10. Edit – Displays Clip Art info and allows you to adjust the image size and position. 

11. Reset – Sets the Clip Art back to the default state. 

12. Custom – Select an image file from your computer to use as Clip Art. 

13. Opacity – Drag the slider left or right to increase or reduce the image 
transparency. Rotation – Drag the slider left or right to apply a rotation. 

 

Fig 10.15.1: Clip Art 

10.15.2. Adding Clip Art 

1. Open the Clip Art tab and click on the Add icon. 

2. Select a category name in the left column (click on the plus expand categories). 

3. Select an item in the preview area, and click Apply to add it to the page. 

4. Close the window when you are done adding images. 

5. Drag the preview slider to increase or reduce the size of the previews. 

6. Click on the up or down arrows next to Quantity to add more of the selected 
image. 

7. Click on the Add to Favorites button to save the selected clip art to Favorites. 

8. The Search field allows you to find clip art by keyword or name. 
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9. Toggle Search selected category only box to limit the search to the current 
category. 

10. Select Browse other to add one of your own clip art images. 

11. To view Royalty-Free content click the only show Royalty-Free content box. 

12. Also, there is a search option to search the desired clip arts 

 

 

Fig 10.15.2: Adding Clip Art 

10.15.3. Cropping Clip Art Images 

 

1. Select a clip art image. 

2. Click on the Crop icon. 

3. Adjust the window to select the area you want to crop and then click Ok. 

 

Fig 10.15.3: Cropping Clip Art Images 
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10.16. Shapes and Lines 

Shapes and lines can be used as design elements in a number of ways. Shapes behind text 
can make the text stand out, or various shapes can make the page more fun. 

 

 

Fig 10.16- Shapes and Lines 

10.16.1. Icon Descriptions: 

1. Add – Add a selected shape to your page. 

2. Line – Add a selected line to your page. 

3. Line Thickness – Change thickness of your selected line. 

4. Arrowhead – Include arrowheads to your selected line. 

5. Line Pattern – Change the line pattern of your selected line. 

6. Border – Add a border around the selected shape. 

7. Shadow – Add a shadow to the selected shape. 

8. Color – Set a color in the selected shape. 

9. Black – Set the shape color to black. 

10. White – Set the shape color to white. 

11. Replace – Swap the selected shape with a different shape. 

12. Paper – Fill the shape with a selected paper from the background categories. 

13. Photo – Fill the shape with a selected photo from your computer. 

14. Mirror – Flip the shape horizontally on the page. 

15. Flip – Flip the shape vertically on the page. 

16. Left – Rotate the shape left 90 degrees. 

17. Right – Rotate the shape right 90 degrees. 

18. Remove – Deletes the shape from the page. 

19. Edit – Displays shape info and allows you to adjust the size and position. 
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20. Reset – Set the shape back to defaults. 

21. Custom – Select your own custom .svg shapefile from your computer. 

22. Opacity – Drag the slider left or right to increase or reduce the shape 
transparency. 

23. Rotation – Drag the slider left or right to apply a rotation. 

 
10.16.2. Adding Shapes 

1. Open the Shapes and Lines tab and click on the Add icon. 

2. Select your desired shape from the Category options and click Apply. 

3. Click Close when done adding shapes. 

 

Fig 10.16.2: Adding Shapes 

10.16.3. Replace Shape 

1. Select a shape on your page with a left-click. 

2. Under the Shapes and Lines tab click on the Replace icon. Select a new shape 
and click Apply. 
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Fig 10.16.3: Replace Shape 

 

 

 

10.16.4. Fill the Shape with the Background Paper: 

1. Select a shape on your page. 

2. Click on the Paper icon. 

3. Select a background paper and click ok. 

 
10.16.5. Fill the Shape with a Photo: 

1. Select a shape on your page. 

2. Click on the Photo icon. 

3. Select an image from your computer and click ok. 

 

 

Fig 10.16.5: Fill the Shape with a Photo 

 

10.17. Draw Line. 

1. Select Shapes and Lines 

2. Click on Line 

3. After selecting the line, then line thickness option will enable now you can adjust 
line thickness according to t your desire 
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Fig 10.17: Draw Line 

 

10.18. Paint 
Fill space behind clip art images with a solid color, paint over parts of a photo so that it blends 

into your background, or draw on the page. 

Icon Descriptions: 

1. Add – Add a paint layer to your page. 

2. Brush – Drag your cursor within the paint layer to add color. 

3. Erase – Drag your cursor within the paint layer to remove added color. 

4. Style – Set the brush style from available shapes. 

5. Color – Set the color of the brush. 

6. Match – Use the color picker to set the brush color from an existing color in the 
project. 

7. Black – Set the color of the brush to black. 

8. White – Set the color of the brush to white. 

9. Mirror – Flip the paint layer horizontally. 

10. Flip – Flip the paint layer vertically. 

11. Left – Rotate the paint layer 90 degrees left. 

12. Right – Rotate the paint layer 90 degrees right. 

13. Remove – Delete the selected paint layer. 

14. Edit – Toggle in and out of the paint mode. 

15. Reset – Reset the paint layer to the originally added state. 
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16. Brush Size – Drag left to make the brush or eraser smaller, drag right to make it larger. 

17. Opacity – Drag the slider left or right to increase or reduce the paint transparency. 

18. Rotation – Drag the slider left or right to apply a rotation. 

 
Fig 10.18: Paint 

 

10.19. Project 

View a list of what was used in your project, preview the project, check it for errors, and 
add, save, or remove page guides. 

Icon Descriptions: 

a) Preview – View your project as a calendar, card, or as a print-quality page.  

b) Spelling –Check all text spelling in the project and displays a list of errors if it 
finds any.  

c) Insert – Add page guides at specific ruler positions on your page. 

d) Remove – Clear all page guides from the current project. 

e) Save – Save the currently set page guides to a template that can be added 
later. 

f) Template – Add previously saved page guides to the current project. 
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Fig 10.19: Project 

10.19.1. Project Preview: 

 

1. Preview – Preview the project as a book, calendar, card or print quality. 

2. Open the Project panel and click on the Preview icon. 

3. Select the desired preview type based on your project and click OK. 

 

 

Fig 10.19.1: Project Preview 

 

10.20. Spell Checker 

1. Check Spelling ‐ Check the project for spelling. 

2. Go to the Check Project Menu > Check Spelling. 

3. You may check a specific page or the entire album, then click OK. 
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4. If the spell checker finds misspelled words, it will launch the Check Spelling dialog. 

a) Ignore – Leaves the current word as it is and moves on to the next misspelling. 

b) Ignore All – Leaves the current word and any identical words in the entire 
project as they are. 

c) Change – Replaces this instance of the word in the Not in dictionary field with 
the one in the Change to the field. 

d) Change All – Replaces this and all subsequent instances of the word in the Not 
in dictionary field with the one in the Change to the field. 

e) Suggest – If the spell checker doesn’t automatically provide alternate words in 
the Suggestions field, click on this button. 

f) Add – Places the current word into the dictionary and continues with the spell 
check process. 

g) Undo – When making multiple changes within the same text box, this allows 
you to return the last word you changed to its former spelling. 

h) Cancel – Exits the spell checker. 

5. If you have questions, go to the support Web page at 
https://encoresupport.freshdesk.com/support/home 

 

10.21. Project Output Preparation 

 

1. PrintMaster 2020 provides flexibility when outputting your project: printing, 
export as JPG, PNG, PDF, uploading to be printed as a photo album, and more. 

2. Careful planning is necessary to take full advantage of this flexibility. Please take 
note of the following considerations when designing a project: 

3. Print – Pay close attention to the paper size of the project type you select when 
creating a project. Many projects use a paper size other than the standard 8.5” x 
11” paper. 

4. Photo Album: The photo album creation process may trim up to 1/2” per page 
side. 

 

https://encoresupport.freshdesk.com/support/home


P a g e  | 82 

 

 

 
Fig 10.21: Project Output Preparation 

 

 

11. Customer Support 
If questions arise while using or installing the software, don’t hesitate to go to the Encore 
website for assistance. 

 

1. Technical Support Website: 

https://encoresupport.freshdesk.com/support/solutions/folders/43000563712 

 

2. How: To Video Tutorials: 
https://www.youtube.com/channel/UCatgw37O3mupzZDSNVxS_yA/videos 

 

3. Forums Support for How-To Questions: http://forums.encoreusa.com/tt.asp?forumid=356 

12. SHARING YOUR PROJECT 
 

Share your project with family and friends as a calendar, card, or digital image file. Icon 
Descriptions. Fig 12 

1. Export: Save your project as JPG or PDF images for viewing or sharing.  

2. Print: Print your project on a home printer. 
 

https://encoresupport.freshdesk.com/support/solutions/folders/43000563712
https://www.youtube.com/channel/UCatgw37O3mupzZDSNVxS_yA/videos
http://forums.encoreusa.com/tt.asp?forumid=356
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Fig 12: Sharing Your Project 

 

Before printing business cards, you may want to create an Avery sheet. 

 
12.1.1. Print 

Print your project pages on a home printer: Fig 13.1 

1. Options: Select printer, copies, paper size, orientation, scaling, and image size. 

2. Printer: Select a printer from the drop-down of available printers. 

3. Copies:  Enter a number for the number of copies you wish to print. 

4. Pages:  Include all or selected pages to print. 

5. Paper Size: Select a paper size and type you wish to print on from the drop-down. 

6. Orientation: Select a landscape or portrait option. 

7. Scale: Scale the image down to fit or print at the actual size that may crop slightly. 

8. Image Size: Print the image at a preset or custom size that will fit on the page. 

 

 

Fig 12.1.1: Print 
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12.1.2. Export 

Save your project as JPG, PNG, or PDF images for viewing and sharing. Fig 13.2 
1. Go to the Share menu > Export. 

2. Select the Image Type, Pages, Size, and Compression then click Finish. 

3. Select the desired Export location (Example: Desktop) and click Save. 

4. A folder will be generated in the set export location with the image files inside. 
 

 

Fig 12.1.2: Export 

 
12.1.3. Image Type  

 

Select the type of image format you wish to create. 

1. JPG: Is a common image format compatible with all systems. 

2. PDF: Allows you to save all pages into a single document for easier viewing. Pages – 
Select which pages are included with export. 

3. Pages with the checkbox in the upper left are selected for export. The Select All 
button will mark all pages for export. 

4. The Clear All button will clear all pages from export. 

 
12.1.4. Image Size:  

 

    Select a size for your exported files. 

1. Larger sizes will give a better quality of printing. 

2. Smaller sizes use less space and are easier to share or send in emails. 
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12.1.5. File Compression: 

 

 Select the quality of the exported files. 

1. 100% creates a better-quality image for printing. 

2. Lower % creates a smaller file size but reduces image quality. (Note: PNG files are not 
affected by compression settings) 



P a g e  | 86 

 

 

 


